import re
regex = re.compile(r"\< *[img][^\\\\>]*[src] *= *[\\\"\\']{0,1}([^\\\"\\'\\ >]*)")
test_str = "<img src=\"//cdn2.jianshu.io/assets/web/logo-58fd04f6f0de908401aa561cda6a0688.png\" alt=\"Logo\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")