package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]:Y(,[A-Z]:Y)*$`)
var str = `S:Y,P:Y,T:Y,A:Y
S:Y,P:Y,T:Y,A:Y,C:Y
S:Y,P:Y,T:Y,A:Y,C:Y,D:Y
A:Y
B:Y
D:Y,F:Y
All the following should never match. Cos 1 or more of them has :N.
S:Y,P:N,T:Y,A:Y
S:Y,P:Y,T:Y,A:Y,C:N
S:Y,P:Y,T:N,A:Y,C:N,D:Y
A:N
B:N
D:Y,F:N`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}