import re
regex = re.compile(r"^[A-Z]:Y(,[A-Z]:Y)*$", flags=re.MULTILINE)
test_str = ("S:Y,P:Y,T:Y,A:Y\n"
"S:Y,P:Y,T:Y,A:Y,C:Y\n"
"S:Y,P:Y,T:Y,A:Y,C:Y,D:Y\n"
"A:Y\n"
"B:Y\n"
"D:Y,F:Y\n\n"
"All the following should never match. Cos 1 or more of them has :N.\n\n"
"S:Y,P:N,T:Y,A:Y\n"
"S:Y,P:Y,T:Y,A:Y,C:N\n"
"S:Y,P:Y,T:N,A:Y,C:N,D:Y\n"
"A:N\n"
"B:N\n"
"D:Y,F:N")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")