import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]:Y(,[A-Z]:Y)*$";
final String string = "S:Y,P:Y,T:Y,A:Y\n"
+ "S:Y,P:Y,T:Y,A:Y,C:Y\n"
+ "S:Y,P:Y,T:Y,A:Y,C:Y,D:Y\n"
+ "A:Y\n"
+ "B:Y\n"
+ "D:Y,F:Y\n\n"
+ "All the following should never match. Cos 1 or more of them has :N.\n\n"
+ "S:Y,P:N,T:Y,A:Y\n"
+ "S:Y,P:Y,T:Y,A:Y,C:N\n"
+ "S:Y,P:Y,T:N,A:Y,C:N,D:Y\n"
+ "A:N\n"
+ "B:N\n"
+ "D:Y,F:N";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}