#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Debuted (.*) and peaked at (.*) on the (.*)\. Source: (.*)\. Label\/Number: (.*)\. Date Peaked: (.*)\."
Local $sString = "Debuted 11/03/1958 and peaked at #38 on the Hot 100 Chart. Source: Pop Annual. Label/Number: Ace 551. Date Peaked: 12/01/1958." & @CRLF & _
"" & @CRLF & _
"Debuted 11/30/1957 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: ABC-Paramount 9871. Date Peaked: 12/28/1957." & @CRLF & _
"" & @CRLF & _
"Debuted 09/15/1958 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: MGM 12677. Date Peaked: 11/10/1958."
Local $sSubst = "$1==$2==$3==$4==$5==$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)