const regex = /Debuted (.*) and peaked at (.*) on the (.*)\. Source: (.*)\. Label\/Number: (.*)\. Date Peaked: (.*)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Debuted (.*) and peaked at (.*) on the (.*)\\. Source: (.*)\\. Label\\\/Number: (.*)\\. Date Peaked: (.*)\\.', 'gm')
const str = `Debuted 11/03/1958 and peaked at #38 on the Hot 100 Chart. Source: Pop Annual. Label/Number: Ace 551. Date Peaked: 12/01/1958.
Debuted 11/30/1957 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: ABC-Paramount 9871. Date Peaked: 12/28/1957.
Debuted 09/15/1958 and peaked at #1 on the Hot 100 Chart. Source: Pop Annual. Label/Number: MGM 12677. Date Peaked: 11/10/1958.`;
const subst = `$1==$2==$3==$4==$5==$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);