const regex = /((.+)\s){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((.+)\\s){3}', 'gm')
const str = `1
2
3
4
5
6
7
8
9
10
`;
const subst = `$0newData\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);