import Foundation
let pattern = #"((.+)\s){3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
2
3
4
5
6
7
8
9
10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0newData\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)