$re = '/((.+)\s){3}/m';
$str = '1
2
3
4
5
6
7
8
9
10
';
$subst = "$0newData\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;