use strict;
my $str = '1
2
3
4
5
6
7
8
9
10
';
my $regex = qr/((.+)\s){3}/mp;
my $subst = '$0newData\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";