#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\n\r].*(\d\.\s+)(?!.*[\n\r](\d\.\s+)).*((<br\s*\/?>){2})"
Local $sString = "<br><br><br>. Do not replace <br> here." & @CRLF & _
"1. One" & @CRLF & _
"2. Two" & @CRLF & _
"3. Three<br><br><br>End of List. Replace first two <br> with \n" & @CRLF & _
"New line follows." & @CRLF & _
"<br><br><br>. Do not replace <br> here."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")