import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n\\r].*(\\d\\.\\s+)(?!.*[\\n\\r](\\d\\.\\s+)).*((<br\\s*\\/?>){2})";
final String string = "<br><br><br>. Do not replace <br> here.\n"
+ "1. One\n"
+ "2. Two\n"
+ "3. Three<br><br><br>End of List. Replace first two <br> with \\n\n"
+ "New line follows.\n"
+ "<br><br><br>. Do not replace <br> here.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}