re = /[\n\r].*(\d\.\s+)(?!.*[\n\r](\d\.\s+)).*((<br\s*\/?>){2})/m
str = '<br><br><br>. Do not replace <br> here.
1. One
2. Two
3. Three<br><br><br>End of List. Replace first two <br> with \\n
New line follows.
<br><br><br>. Do not replace <br> here.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end