const regex = /[\n\r].*(\d\.\s+)(?!.*[\n\r](\d\.\s+)).*((<br\s*\/?>){2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\n\\r].*(\\d\\.\\s+)(?!.*[\\n\\r](\\d\\.\\s+)).*((<br\\s*\\\/?>){2})', 'gm')
const str = `<br><br><br>. Do not replace <br> here.
1. One
2. Two
3. Three<br><br><br>End of List. Replace first two <br> with \\n
New line follows.
<br><br><br>. Do not replace <br> here.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}