using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a+ #some ""a""
b+ #some ""b""
[cd]+ #some ""c"" and ""d"" in any order";
string input = @"abbbdcad";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}