$re = '/a+ #some "a"
b+ #some "b"
[cd]+ #some "c" and "d" in any order/mx';
$str = 'abbbdcad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);