package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a+ #some "a"
b+ #some "b"
[cd]+ #some "c" and "d" in any order`)
var str = `abbbdcad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}