re = /a+ #some "a"
b+ #some "b"
[cd]+ #some "c" and "d" in any order/mx
str = 'abbbdcad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end