re = /(²²\w+²²:)(\{²²data²²:\w+,²²scope²²:\w+,²²locale²²:\w+\})/m
str = '{²²identifier²²:²²506078_CNG²²,²²values²²:{²²active_akeneo_fr²²:{²²data²²:1,²²scope²²:null,²²locale²²:1},²²active_akeneo_be²²:{²²data²²:1,²²scope²²:null,²²locale²²:null}}}'
subst = '\\1[\\2]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result