#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\b91|\b0|\b)([6-9]\d{9})\b"
Local $sString = "9207323601" & @CRLF & _
"8343434349" & @CRLF & _
"6790312345" & @CRLF & _
"9739393939" & @CRLF & _
"7777598086" & @CRLF & _
"my number is 7777598086" & @CRLF & _
"7777598086-" & @CRLF & _
"91-7777598086" & @CRLF & _
"+91-7777598086" & @CRLF & _
"+917777598086" & @CRLF & _
"+917777598086 is my number" & @CRLF & _
"07777598086" & @CRLF & _
"+91-07777598086" & @CRLF & _
"" & @CRLF & _
"invalid inputs:" & @CRLF & _
"92073236011" & @CRLF & _
"47777598086" & @CRLF & _
"s77777598086" & @CRLF & _
"77777598086s" & @CRLF & _
"777777598086" & @CRLF & _
"1077777598086" & @CRLF & _
"+91077777598086" & @CRLF & _
"123149177777598086"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")