using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b91|\b0|\b)([6-9]\d{9})\b";
string input = @"9207323601
8343434349
6790312345
9739393939
7777598086
my number is 7777598086
7777598086-
91-7777598086
+91-7777598086
+917777598086
+917777598086 is my number
07777598086
+91-07777598086
invalid inputs:
92073236011
47777598086
s77777598086
77777598086s
777777598086
1077777598086
+91077777598086
123149177777598086";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}