const regex = /(\b91|\b0|\b)([6-9]\d{9})\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b91|\\b0|\\b)([6-9]\\d{9})\\b', 'gi')
const str = `9207323601
8343434349
6790312345
9739393939
7777598086
my number is 7777598086
7777598086-
91-7777598086
+91-7777598086
+917777598086
+917777598086 is my number
07777598086
+91-07777598086
invalid inputs:
92073236011
47777598086
s77777598086
77777598086s
777777598086
1077777598086
+91077777598086
123149177777598086`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}