#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*+(?=[\s\S]*[\u4e00-\u9fa5])[\s\S]+?\*\/"
Local $sString = "/**" & @CRLF & _
"" & @CRLF & _
"事件类型" & @CRLF & _
"1 subscribe 关注" & @CRLF & _
"2 unsubscribe 取关" & @CRLF & _
"3 SCAN (用户已关注)扫码" & @CRLF & _
"4 LOCATION 上报地理位置" & @CRLF & _
"5 CLICK 点击菜单拉消息" & @CRLF & _
"6 VIEW 点击菜单跳转连接" & @CRLF & _
"*/" & @CRLF & _
"lksdjflkfdlsfkfkkf" & @CRLF & _
"/**" & @CRLF & _
"" & @CRLF & _
"事件类型" & @CRLF & _
"1 subscribe 关注" & @CRLF & _
"2 unsubscribe 取关" & @CRLF & _
"3 SCAN (用户已关注)扫码" & @CRLF & _
"4 LOCATION 上报地理位置" & @CRLF & _
"5 CLICK 点击菜单拉消息" & @CRLF & _
"6 VIEW 点击菜单跳转连接" & @CRLF & _
"*/" & @CRLF & _
"jsdlkfjfkfksldfj(){}" & @CRLF & _
"/**" & @CRLF & _
"" & @CRLF & _
"事件类型" & @CRLF & _
"1 subscribe 关注" & @CRLF & _
"2 unsubscribe 取关" & @CRLF & _
"3 SCAN (用户已关注)扫码" & @CRLF & _
"4 LOCATION 上报地理位置" & @CRLF & _
"5 CLICK 点击菜单拉消息" & @CRLF & _
"6 VIEW 点击菜单跳转连接" & @CRLF & _
"*/" & @CRLF & _
"jsdfkljfld" & @CRLF & _
"/**" & @CRLF & _
"" & @CRLF & _
"1 subscribe " & @CRLF & _
"2 unsubscribe " & @CRLF & _
"3 SCAN " & @CRLF & _
"4 LOCATION " & @CRLF & _
"5 CLICK " & @CRLF & _
"6 VIEW " & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")