const regex = /\/\*+(?=[\s\S]*[\u4e00-\u9fa5])[\s\S]+?\*\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*+(?=[\\s\\S]*[\\u4e00-\\u9fa5])[\\s\\S]+?\\*\\\/', 'gm')
const str = `/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
lksdjflkfdlsfkfkkf
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdlkfjfkfksldfj(){}
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdfkljfld
/**
1 subscribe
2 unsubscribe
3 SCAN
4 LOCATION
5 CLICK
6 VIEW
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}