using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*+(?=[\s\S]*[\u4e00-\u9fa5])[\s\S]+?\*\/";
string input = @"/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
lksdjflkfdlsfkfkkf
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdlkfjfkfksldfj(){}
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdfkljfld
/**
1 subscribe
2 unsubscribe
3 SCAN
4 LOCATION
5 CLICK
6 VIEW
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}