use strict;
my $str = '/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
lksdjflkfdlsfkfkkf
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdlkfjfkfksldfj(){}
/**
事件类型
1 subscribe 关注
2 unsubscribe 取关
3 SCAN (用户已关注)扫码
4 LOCATION 上报地理位置
5 CLICK 点击菜单拉消息
6 VIEW 点击菜单跳转连接
*/
jsdfkljfld
/**
1 subscribe
2 unsubscribe
3 SCAN
4 LOCATION
5 CLICK
6 VIEW
*/';
my $regex = qr/\/\*+(?=[\s\S]*[\u4e00-\u9fa5])[\s\S]+?\*\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}