import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Caption\\s*ProcessId((?:\\r\\r\\n)([a-zA-z\\W]+.exe)\\s*(\\d+)\\s*)*";
final String string = "Caption ProcessId\\r\\r\\nnotepad++.exe 40000 \\r\\r\\nnfilezilla.exe 90000 \\r\\r\\n\\r\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}