import re
regex = re.compile(r"Caption\s*ProcessId((?:\r\r\n)([a-zA-z\W]+.exe)\s*(\d+)\s*)*", flags=re.IGNORECASE | re.MULTILINE)
test_str = "Caption ProcessId\\r\\r\\nnotepad++.exe 40000 \\r\\r\\nnfilezilla.exe 90000 \\r\\r\\n\\r\\r\\n"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")