re = /Caption\s*ProcessId((?:\r\r\n)([a-zA-z\W]+.exe)\s*(\d+)\s*)*/im
str = 'Caption ProcessId\\r\\r\\nnotepad++.exe 40000 \\r\\r\\nnfilezilla.exe 90000 \\r\\r\\n\\r\\r\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end