const regex = /Caption\s*ProcessId((?:\r\r\n)([a-zA-z\W]+.exe)\s*(\d+)\s*)*/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Caption\\s*ProcessId((?:\\r\\r\\n)([a-zA-z\\W]+.exe)\\s*(\\d+)\\s*)*', 'img')
const str = `Caption ProcessId\\r\\r\\nnotepad++.exe 40000 \\r\\r\\nnfilezilla.exe 90000 \\r\\r\\n\\r\\r\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}