using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\S+\s*?){3})(\s+)(.*?)$";
string input = @"io sarò qui con voi
Scrivo qui alcune parole
Come quando fuori piove ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}