re = /^((\S+\s*?){3})(\s+)(.*?)$/m
str = 'io sarò qui con voi
Scrivo qui alcune parole
Come quando fuori piove '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end