package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bfor\h+(\w+\h+\d{1,2},\h+\d{4})\h+to\h+((?1))\b`)
var str = `for April 1, 2017 to April 30, 2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}