import re
regex = re.compile(r"\bfor\h+(\w+\h+\d{1,2},\h+\d{4})\h+to\h+((?1))\b")
test_str = "for April 1, 2017 to April 30, 2017"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")