// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bfor\h+(\w+\h+\d{1,2},\h+\d{4})\h+to\h+((?1))\b").unwrap();
let string = "for April 1, 2017 to April 30, 2017";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}