re = /\bfor\h+(\w+\h+\d{1,2},\h+\d{4})\h+to\h+((?1))\b/
str = 'for April 1, 2017 to April 30, 2017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end