#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d*)(?:([-:])([1-9]\d*)(?:(/)([1-9]\d*))?)?$"
Local $sString = "ex: " & @CRLF & _
"6" & @CRLF & _
"1-6" & @CRLF & _
"6:4" & @CRLF & _
"10-20/3" & @CRLF & _
"" & @CRLF & _
"2048-4096/100" & @CRLF & _
"15:10/3" & @CRLF & _
"2048-4096/100" & @CRLF & _
"" & @CRLF & _
"NOT:" & @CRLF & _
"5/3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")