import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d*)(?:([-:])([1-9]\\d*)(?:(/)([1-9]\\d*))?)?$";
final String string = "ex: \n"
+ "6\n"
+ "1-6\n"
+ "6:4\n"
+ "10-20/3\n\n"
+ "2048-4096/100\n"
+ "15:10/3\n"
+ "2048-4096/100\n\n"
+ "NOT:\n"
+ "5/3\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}