const regex = new RegExp('^([1-9]\\d*)(?:([-:])([1-9]\\d*)(?:(/)([1-9]\\d*))?)?$', 'gm')
const str = `ex:
6
1-6
6:4
10-20/3
2048-4096/100
15:10/3
2048-4096/100
NOT:
5/3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}