package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d*)(?:([-:])([1-9]\d*)(?:(/)([1-9]\d*))?)?$`)
var str = `ex:
6
1-6
6:4
10-20/3
2048-4096/100
15:10/3
2048-4096/100
NOT:
5/3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}