using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[[^\s\/]+:\/*(\/[^]]*)\]*\[[^]]*\]\]";
string substitution = @"$1";
string input = @"[[file://////abc/def/ghi][Abc Def Ghi]] ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}