re = /\[\[[^\s\/]+:\/*(\/[^]]*)\]*\[[^]]*\]\]/m
str = '[[file://////abc/def/ghi][Abc Def Ghi]] '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result