import re
regex = re.compile(r"\[\[[^\s\/]+:\/*(\/[^]]*)\]*\[[^]]*\]\]", flags=re.MULTILINE)
test_str = "[[file://////abc/def/ghi][Abc Def Ghi]] "
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)