$re = '/\[\[[^\s\/]+:\/*(\/[^]]*)\]*\[[^]]*\]\]/m';
$str = '[[file://////abc/def/ghi][Abc Def Ghi]] ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;