#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<day>[0-3]?[0-9])( *\/ *|\. *| )(?<month>januar|februar|marts|april|maj|juni|juli|august|september|oktober|november|december|jan|feb|mar|apr|maj|juni|juli|aug|sept|okt|nov|dec|[0-3]?[0-9])( *\/? *)(?<year>\d{4})*[-kl:.\t ]*(?<startTime>\d{2,2}[.:]\d{2})*[-\t ]*(?<endTime>\d{2}[.:]\d{2})*"
Local $sString = "Lørdag den 01. december 2018 kl. 15:00 - 17.30 " & @CRLF & _
"01 / 12" & @CRLF & _
"01 / 12" & @CRLF & _
"den 01 December." & @CRLF & _
"01 / 12" & @CRLF & _
"den 01 april." & @CRLF & _
"ma. Den 01 DEC. 2000 kl 15.00 - 17:30 " & @CRLF & _
"01/04" & @CRLF & _
"01/4" & @CRLF & _
"01 dec" & @CRLF & _
"den 01 apr." & @CRLF & _
"____" & @CRLF & _
"01 12" & @CRLF & _
"01:13" & @CRLF & _
" 01 personer til et macaron kursus." & @CRLF & _
"DKK 300 pr. deltager." & @CRLF & _
"2400 DKK." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")