use strict;
my $str = 'Lørdag den 01. december 2018 kl. 15:00 - 17.30
01 / 12
01 / 12
den 01 December.
01 / 12
den 01 april.
ma. Den 01 DEC. 2000 kl 15.00 - 17:30
01/04
01/4
01 dec
den 01 apr.
____
01 12
01:13
01 personer til et macaron kursus.
DKK 300 pr. deltager.
2400 DKK.
';
my $regex = qr/(?<day>[0-3]?[0-9])( *\/ *|\. *| )(?<month>januar|februar|marts|april|maj|juni|juli|august|september|oktober|november|december|jan|feb|mar|apr|maj|juni|juli|aug|sept|okt|nov|dec|[0-3]?[0-9])( *\/? *)(?<year>\d{4})*[-kl:.\t ]*(?<startTime>\d{2,2}[.:]\d{2})*[-\t ]*(?<endTime>\d{2}[.:]\d{2})*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}