import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<day>[0-3]?[0-9])( *\\/ *|\\. *| )(?<month>januar|februar|marts|april|maj|juni|juli|august|september|oktober|november|december|jan|feb|mar|apr|maj|juni|juli|aug|sept|okt|nov|dec|[0-3]?[0-9])( *\\/? *)(?<year>\\d{4})*[-kl:.\\t ]*(?<startTime>\\d{2,2}[.:]\\d{2})*[-\\t ]*(?<endTime>\\d{2}[.:]\\d{2})*";
final String string = "Lørdag den 01. december 2018 kl. 15:00 - 17.30 \n"
+ "01 / 12\n"
+ "01 / 12\n"
+ "den 01 December.\n"
+ "01 / 12\n"
+ "den 01 april.\n"
+ "ma. Den 01 DEC. 2000 kl 15.00 - 17:30 \n"
+ "01/04\n"
+ "01/4\n"
+ "01 dec\n"
+ "den 01 apr.\n"
+ "____\n"
+ "01 12\n"
+ "01:13\n"
+ " 01 personer til et macaron kursus.\n"
+ "DKK 300 pr. deltager.\n"
+ "2400 DKK.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}