import re
regex = re.compile(r"(?<day>[0-3]?[0-9])( *\/ *|\. *| )(?<month>januar|februar|marts|april|maj|juni|juli|august|september|oktober|november|december|jan|feb|mar|apr|maj|juni|juli|aug|sept|okt|nov|dec|[0-3]?[0-9])( *\/? *)(?<year>\d{4})*[-kl:.\t ]*(?<startTime>\d{2,2}[.:]\d{2})*[-\t ]*(?<endTime>\d{2}[.:]\d{2})*", flags=re.IGNORECASE)
test_str = ("Lørdag den 01. december 2018 kl. 15:00 - 17.30 \n"
"01 / 12\n"
"01 / 12\n"
"den 01 December.\n"
"01 / 12\n"
"den 01 april.\n"
"ma. Den 01 DEC. 2000 kl 15.00 - 17:30 \n"
"01/04\n"
"01/4\n"
"01 dec\n"
"den 01 apr.\n"
"____\n"
"01 12\n"
"01:13\n"
" 01 personer til et macaron kursus.\n"
"DKK 300 pr. deltager.\n"
"2400 DKK.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")