const regex = /<a.+?href=["'](?!\.\.)([^"']+)["'].*?>(.+?)<\/a>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.+?href=["\'](?!\\.\\.)([^"\']+)["\'].*?>(.+?)<\\\/a>', 'gim')
const str = `<a href="..">..</a></td><a href="Example.pdf">Example.pdf</a>
<a href="www.example.com">Example.pdf</a>
<a href="http://www.example.com">Example.pdf</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}