re = /<a.+?href=["'](?!\.\.)([^"']+)["'].*?>(.+?)<\/a>/im
str = '<a href="..">..</a></td><a href="Example.pdf">Example.pdf</a>
<a href="www.example.com">Example.pdf</a>
<a href="http://www.example.com">Example.pdf</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end